Supported Browsers

Google Chrome (the latest version)

If you use a different browser such as Internet Explorer, we can't promise an optimal experience, so we highly suggest you use the latest version of Google Chrome!

If you're facing issues with Ducky because you're Google Chrome isn't updated, here's a guide to how you can update your Google Chrome. We recommend having the latest version to make sure you're protected by the latest security updates.

Keywords: #Doesn't work

 


Did this help answer your question?

thumbs up
thumbs down

Thanks for the feedback! 🙏🏽